Core - Billing isn't accessible at the moment

Resolved
Major outage
Started 17 days ago Lasted 4 minutes

Affected

Core
Billing
Updates
  • Resolved
    Resolved

    Core - Billing All services are now operational

  • Investigating
    Investigating

    Core - Billing We've been made aware of a possible service disruption. We will update you when we know more.