Billing Update

Completed
Scheduled for March 23, 2023 at 5:00 PM – 5:10 PM

Affects

Core
Billing
Updates
  • Completed
    March 23, 2023 at 5:10 PM
    Completed
    March 23, 2023 at 5:10 PM

    Maintenance has completed successfully.

  • In progress
    March 23, 2023 at 5:00 PM
    In progress
    March 23, 2023 at 5:00 PM

    Maintenance is now in progress

  • Planned
    March 23, 2023 at 5:00 PM
    Planned
    March 23, 2023 at 5:00 PM

    We will be performing updates to our billing system. This should only involve five minutes of downtime, however we are scheduling a two hour window for the work.