billing update

Completed
Scheduled for March 09, 2024 at 7:00 PM – 8:20 PM

Affects

Core
Billing
Updates
  • Completed
    March 09, 2024 at 8:20 PM
    Completed
    March 09, 2024 at 8:20 PM
    Maintenance has completed successfully.
  • In progress
    March 09, 2024 at 7:00 PM
    In progress
    March 09, 2024 at 7:00 PM
    Maintenance is now in progress
  • Planned
    March 09, 2024 at 7:00 PM
    Planned
    March 09, 2024 at 7:00 PM

    We will be performing updates to our billing system. This should only involve five minutes of downtime, however we are scheduling a two hour window for the work.